[packaging] [Bug 523] Upgrade problem

Kolab Bugzilla noreply at kolab.org
Wed Nov 30 00:44:49 CET 2011


https://issues.kolab.org/show_bug.cgi?id=523

--- Comment #4 from John McMonagle <johnm at advocap.org> 2011-11-30 00:44:42 CET ---
(In reply to comment #3)
> (In reply to comment #0)
> > Was comparing the upgraded installation to a clean install and noticed that 
> > PEAR-PHPUnit-Channel  rpm was installed on the upgraded installation but not 
> > the clean install.
> > I removed PEAR-PHPUnit-Channel.
> 
> Yes, was correct. 
> 
> > Now email to johnm+spam at advocap.org works.
> 
> I doubt that this is related.
I did a quick check of what that package was it was and I was pretty sure it
would have no effect.
Anyhow it started working after that.
I was restarting kolab after ever change I tried.
Had a couple mails stuck in the mail queue.
Just reporting what happened.
Maybe if someone else has this problem they can try it.

> 
> > I assume it should have been removed by the upgrade scripts.
> 
> No, you have have to remove it manually, see the 2.3.0 upgrade instructions in
> 1st.README.

Looked in the 1st.README of 2.3.0 and 2.3.4 and they have this:
/kolab/bin/openpkg rpm -e --nodeps kolabd PHPUnit
I had done that.
Nothing about removing PEAR-PHPUnit-Channel

Nothing on PEAR-PHPUnit-Channel anywhere in 1st.README.
There is mention in release notes for
Changes between 2.3-alpha and 2.3.0
Notes it's removed but not an indication one needs to do anything.

john

-- 
Configure bugmail: https://issues.kolab.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.


More information about the packaging-bugs mailing list