[packaging] [Bug 636] New: Build failure: curl breaks due to conflicting types with libssh2

Kolab Bugzilla noreply at kolab.org
Fri Mar 16 09:39:31 CET 2012


https://issues.kolab.org/show_bug.cgi?id=636

           Summary: Build failure: curl breaks due to conflicting types
                    with libssh2
           Product: Kolab
           Version: 2.3.4
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: major
          Priority: P3
         Component: packaging - openpkg
        AssignedTo: wickert at kolabsys.com
        ReportedBy: florian-evers at gmx.de
         QAContact: packaging-bugs at lists.kolabsys.com
       Ticket Type: ---


Created attachment 123
  --> https://issues.kolab.org/attachment.cgi?id=123
Build log with failure message

Hello,

I'm running Gentoo Linux here, and can confirm this build failure ob two amd64
boxes. I followed the installation docs for a fresh install: downloading the
files, and starting the build process afterwards.

However, the build process stops on both boxes after a short time span with the
same error message:

 /usr/bin/gcc -DHAVE_CONFIG_H -I../include -I../lib -I../lib
-I/tmp/openpkg-20071227/curl-7.17.1/../zlib-1.2.3
-I/tmp/openpkg-20071227/curl-7.17.1/../openssl-0.9.8g/include/openssl
-I/tmp/openpkg-20071227/curl-7.17.1/../openssl-0.9.8g/include
-I/tmp/openpkg-20071227/curl-7.17.1/../zlib-1.2.3/include
-I/tmp/openpkg-20071227/curl-7.17.1/../zlib-1.2.3 -MT ssh.lo -MD -MP -MF
.deps/ssh.Tpo -c ssh.c  -fPIC -DPIC -o ssh.o
ssh.c:133:8: error: conflicting types for 'libssh2_free'
/usr/include/libssh2.h:442:18: note: previous declaration of 'libssh2_free' was
here
make[2]: *** [ssh.lo] Error 1
make[2]: Leaving directory `/tmp/openpkg-20071227/curl-7.17.1/lib'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/tmp/openpkg-20071227/curl-7.17.1/lib'
make: *** [all-recursive] Error 1
+ exit 2
+ exit 2
./openpkg.boot:ERROR: script returned non-null value

For me, it seems that there is a version mismatch between the system files on
my box and the files assumed by the kolab build chain.

net-libs/libssh2-1.3.0 
dev-libs/openssl-1.0.0h

I hope this helps you identifying the problem.

Regards,
Florian

-- 
Configure bugmail: https://issues.kolab.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.


More information about the packaging-bugs mailing list