[packaging] [Bug 3981] New: kolab 3.3 el7 rpms require mariadb-server, conflict with mariadb-galera-server

Kolab Bugzilla noreply at kolab.org
Tue Nov 25 15:42:15 CET 2014


https://issues.kolab.org/show_bug.cgi?id=3981

            Bug ID: 3981
           Summary: kolab 3.3 el7 rpms require mariadb-server, conflict
                    with mariadb-galera-server
    Classification: Kolab Server
           Product: Kolab Server
           Version: 3.3
          Hardware: PC
                OS: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: P3
         Component: packaging
          Assignee: packaging-bugs at lists.kolabsys.com
          Reporter: pasik at iki.fi
       Ticket Type: ---

I have Kolab 3.3 environment, which was installed pretty much immediately when
kolab 3.3 centos7 packages first became available.

I'm running mariadb-galera-server from epel el7 repo, because this package
"provides" mysql-server, which was required be the early kolab 3.3 rpms:

# rpm -qa | grep ^kolab-3
kolab-3.1.8-4.2.el7.kolab_3.3.noarch

# rpm -q kolab --requires
kolab-cli
kolab-conf
kolab-imap
kolab-ldap
kolab-mta
kolab-saslauthd
kolab-server
kolab-utils
kolab-webadmin
kolab-webclient
mysql-server
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1

# rpm -q mariadb-galera-server --provides
config(mariadb-galera-server) = 1:5.5.37-2.el7
libdaemon_example.so()(64bit)
mariadb-galera-server = 1:5.5.37-2.el7
mariadb-galera-server(x86-64) = 1:5.5.37-2.el7
mysql-compat-server = 1:5.5.37-2.el7
mysql-compat-server(x86-64) = 1:5.5.37-2.el7
mysql-server = 1:5.5.37-2.el7
mysql-server(x86-64) = 1:5.5.37-2.el7


Running "yum update" today results in this:

Resolving Dependencies
--> Running transaction check
---> Package kolab.noarch 0:3.1.8-4.2.el7.kolab_3.3 will be updated
---> Package kolab.noarch 0:3.1.8-4.4.el7.kolab_3.3 will be an update
--> Processing Dependency: mariadb-server for package:
kolab-3.1.8-4.4.el7.kolab_3.3.noarch
--> Running transaction check
---> Package mariadb-server.x86_64 1:5.5.40-1.el7_0 will be installed
--> Processing Dependency: mariadb-libs(x86-64) = 1:5.5.40-1.el7_0 for package:
1:mariadb-server-5.5.40-1.el7_0.x86_64
--> Processing Dependency: mariadb(x86-64) = 1:5.5.40-1.el7_0 for package:
1:mariadb-server-5.5.40-1.el7_0.x86_64
--> Running transaction check
---> Package mariadb.x86_64 1:5.5.37-1.el7_0 will be updated
---> Package mariadb.x86_64 1:5.5.40-1.el7_0 will be an update
---> Package mariadb-libs.x86_64 1:5.5.37-1.el7_0 will be updated
---> Package mariadb-libs.x86_64 1:5.5.40-1.el7_0 will be an update
--> Processing Conflict: 1:mariadb-galera-server-5.5.37-2.el7.x86_64 conflicts
mariadb-server
--> Finished Dependency Resolution
Error: mariadb-galera-server conflicts with
1:mariadb-server-5.5.40-1.el7_0.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


It seems kolab rpm now requires "mariadb-server" instead of "mysql-server":

# rpm -qp kolab-3.1.8-4.4.el7.kolab_3.3.noarch.rpm --requires
kolab-cli
kolab-conf
kolab-imap
kolab-ldap
kolab-mta
kolab-saslauthd
kolab-server
kolab-utils
kolab-webadmin
kolab-webclient
mariadb-server
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1


Is it possible to change that "requires" to be mariadb-server OR
mariadb-galera-server ?  mariadb-galera-server is an option that should be
allowed to be used together with kolab. 

It'd be nice if mariadb-galera-server provided "mariadb-server" though.. but
that doesn't seem to be the case today.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.kolabsys.com/pipermail/packaging-bugs/attachments/20141125/325eefc6/attachment.htm>


More information about the packaging-bugs mailing list