[packaging] [Bug 5149] New: Dependency issue with enabled dev repo for certain roundcube version

Kolab Bugzilla noreply at kolab.org
Tue Jul 14 19:45:21 CEST 2015


https://issues.kolab.org/show_bug.cgi?id=5149

            Bug ID: 5149
           Summary: Dependency issue with enabled dev repo for certain
                    roundcube version
    Classification: Kolab Server
           Product: Kolab Server
           Version: 14
          Hardware: PC
                OS: Enterprise Linux 6
            Status: UNCONFIRMED
          Severity: normal
          Priority: P3
         Component: packaging
          Assignee: packaging-bugs at lists.kolabsys.com
          Reporter: dirk at marschner.cx
                CC: petersen at kolabsys.com, robert.bender at lhm.mykolab.com
       Ticket Type: ---

Customer has enabled all KE14 repositories on there systems.

When I try to install a certain roundcube version like

yum install roundcubemail-1.1.1.3-1.el6.kolab_14

I receive the following dependency problem:

kolab-14                                                                       
                       | 2.5 kB     00:00     
kolab-14/primary_db                                                            
                       | 121 kB     00:00     
kolab-14-development                                                           
                       | 2.5 kB     00:00     
kolab-14-development/primary_db                                                
                       | 247 kB     00:00     
kolab-14-extras-audit                                                          
                       | 2.5 kB     00:00     
kolab-14-extras-audit/primary_db                                               
                       |  26 kB     00:00     
kolab-14-updates                                                               
                       | 2.5 kB     00:00     
kolab-14-updates/primary_db                                                    
                       | 5.0 kB     00:00     
kolab-14-updates-testing                                                       
                       | 2.5 kB     00:00     
kolab-14-updates-testing/primary_db                                            
                       | 311 kB     00:00     
puppetlabs-deps-el6                                                            
                       | 2.5 kB     00:00     
puppetlabs-deps-el6/primary_db                                                 
                       |  29 kB     00:00     
puppetlabs-products-el6                                                        
                       | 2.5 kB     00:00     
puppetlabs-products-el6/primary_db                                             
                       | 166 kB     00:00     
Löse Abhängigkeiten auf
--> Führe Transaktionsprüfung aus
---> Package roundcubemail.noarch 0:1.1.1.3-1.el6.kolab_14 will be installiert
--> Verarbeite Abhängigkeiten: roundcubemail(plugin-password) =
1.1.1.3-1.el6.kolab_14 für Paket: roundcubemail-1.1.1.3-1.el6.kolab_14.noarch
--> Verarbeite Abhängigkeiten: roundcubemail(plugin-managesieve) =
1.1.1.3-1.el6.kolab_14 für Paket: roundcubemail-1.1.1.3-1.el6.kolab_14.noarch
--> Verarbeite Abhängigkeiten: roundcubemail(plugin-acl) =
1.1.1.3-1.el6.kolab_14 für Paket: roundcubemail-1.1.1.3-1.el6.kolab_14.noarch
--> Verarbeite Abhängigkeiten: roundcubemail(core) = 1.1.1.3-1.el6.kolab_14 für
Paket: roundcubemail-1.1.1.3-1.el6.kolab_14.noarch
--> Verarbeite Abhängigkeiten: roundcubemail-skin-enterprise für Paket:
roundcubemail-1.1.1.3-1.el6.kolab_14.noarch
--> Führe Transaktionsprüfung aus
---> Package roundcubemail-core.noarch 0:1.1.1.3-1.el6.kolab_14 will be
installiert
--> Verarbeite Abhängigkeiten: roundcubemail(skin) = 1.1.1.3-1.el6.kolab_14 für
Paket: roundcubemail-core-1.1.1.3-1.el6.kolab_14.noarch
--> Verarbeite Abhängigkeiten: roundcubemail(plugin-jqueryui) =
1.1.1.3-1.el6.kolab_14 für Paket:
roundcubemail-core-1.1.1.3-1.el6.kolab_14.noarch
--> Verarbeite Abhängigkeiten: roundcubemail(plugin-filesystem_attachments) =
1.1.1.3-1.el6.kolab_14 für Paket:
roundcubemail-core-1.1.1.3-1.el6.kolab_14.noarch
--> Verarbeite Abhängigkeiten: roundcubemail(core-assets) =
1.1.1.3-1.el6.kolab_14 für Paket:
roundcubemail-core-1.1.1.3-1.el6.kolab_14.noarch
---> Package roundcubemail-plugin-acl.noarch 0:1.1.1.3-1.el6.kolab_14 will be
installiert
--> Verarbeite Abhängigkeiten: roundcubemail(plugin-acl-skin) =
1.1.1.3-1.el6.kolab_14 für Paket:
roundcubemail-plugin-acl-1.1.1.3-1.el6.kolab_14.noarch
--> Verarbeite Abhängigkeiten: roundcubemail(plugin-acl-assets) =
1.1.1.3-1.el6.kolab_14 für Paket:
roundcubemail-plugin-acl-1.1.1.3-1.el6.kolab_14.noarch
---> Package roundcubemail-plugin-managesieve.noarch 0:1.1.1.3-1.el6.kolab_14
will be installiert
--> Verarbeite Abhängigkeiten: roundcubemail(plugin-managesieve-skin) =
1.1.1.3-1.el6.kolab_14 für Paket:
roundcubemail-plugin-managesieve-1.1.1.3-1.el6.kolab_14.noarch
--> Verarbeite Abhängigkeiten: roundcubemail(plugin-managesieve-assets) =
1.1.1.3-1.el6.kolab_14 für Paket:
roundcubemail-plugin-managesieve-1.1.1.3-1.el6.kolab_14.noarch
---> Package roundcubemail-plugin-password.noarch 0:1.1.1.3-1.el6.kolab_14 will
be installiert
--> Verarbeite Abhängigkeiten: roundcubemail(plugin-password-assets) =
1.1.1.3-1.el6.kolab_14 für Paket:
roundcubemail-plugin-password-1.1.1.3-1.el6.kolab_14.noarch
---> Package roundcubemail-skin-enterprise.noarch 0:0.3.4-1.el6.kolab_14 will
be installiert
--> Verarbeite Abhängigkeiten: roundcubemail(skin-enterprise-assets) =
0.3.4-1.el6.kolab_14 für Paket:
roundcubemail-skin-enterprise-0.3.4-1.el6.kolab_14.noarch
--> Verarbeite Abhängigkeiten: roundcubemail(skin-enterprise) =
0.3.4-1.el6.kolab_14 für Paket:
roundcubemail-skin-enterprise-0.3.4-1.el6.kolab_14.noarch
--> Führe Transaktionsprüfung aus
---> Package roundcubemail-core-assets.noarch 0:1.1.1.3-1.el6.kolab_14 will be
installiert
---> Package roundcubemail-plugin-acl-assets.noarch 0:1.1.1.3-1.el6.kolab_14
will be installiert
---> Package roundcubemail-plugin-acl-skin-larry.noarch
0:1.1.1.3-1.el6.kolab_14 will be installiert
--> Verarbeite Abhängigkeiten: roundcubemail(plugin-acl-skin-larry-assets) =
1.1.1.3-1.el6.kolab_14 für Paket:
roundcubemail-plugin-acl-skin-larry-1.1.1.3-1.el6.kolab_14.noarch
---> Package roundcubemail-plugin-filesystem_attachments.noarch
0:1.1.1.3-1.el6.kolab_14 will be installiert
--> Verarbeite Abhängigkeiten:
roundcubemail(plugin-filesystem_attachments-assets) = 1.1.1.3-1.el6.kolab_14
für Paket:
roundcubemail-plugin-filesystem_attachments-1.1.1.3-1.el6.kolab_14.noarch
---> Package roundcubemail-plugin-jqueryui.noarch 0:1.1.1.3-1.el6.kolab_14 will
be installiert
--> Verarbeite Abhängigkeiten: roundcubemail(plugin-jqueryui-skin) =
1.1.1.3-1.el6.kolab_14 für Paket:
roundcubemail-plugin-jqueryui-1.1.1.3-1.el6.kolab_14.noarch
--> Verarbeite Abhängigkeiten: roundcubemail(plugin-jqueryui-assets) =
1.1.1.3-1.el6.kolab_14 für Paket:
roundcubemail-plugin-jqueryui-1.1.1.3-1.el6.kolab_14.noarch
---> Package roundcubemail-plugin-managesieve-assets.noarch
0:1.1.1.3-1.el6.kolab_14 will be installiert
---> Package roundcubemail-plugin-managesieve-skin-larry.noarch
0:1.1.1.3-1.el6.kolab_14 will be installiert
--> Verarbeite Abhängigkeiten:
roundcubemail(plugin-managesieve-skin-larry-assets) = 1.1.1.3-1.el6.kolab_14
für Paket:
roundcubemail-plugin-managesieve-skin-larry-1.1.1.3-1.el6.kolab_14.noarch
---> Package roundcubemail-plugin-password-assets.noarch
0:1.1.1.3-1.el6.kolab_14 will be installiert
---> Package roundcubemail-skin-enterprise-assets.noarch 0:0.3.4-1.el6.kolab_14
will be installiert
--> Verarbeite Abhängigkeiten: roundcubemail(skin-larry-assets) >= 1.1 für
Paket: roundcubemail-skin-enterprise-assets-0.3.4-1.el6.kolab_14.noarch
---> Package roundcubemail-skin-enterprise-core.noarch 0:0.3.4-1.el6.kolab_14
will be installiert
---> Package roundcubemail-skin-larry.noarch 0:1.1.1.3-1.el6.kolab_14 will be
installiert
--> Verarbeite Abhängigkeiten: roundcubemail(skin-larry-assets) =
1.1.1.3-1.el6.kolab_14 für Paket:
roundcubemail-skin-larry-1.1.1.3-1.el6.kolab_14.noarch
--> Führe Transaktionsprüfung aus
---> Package roundcubemail-plugin-acl-skin-larry-assets.noarch
0:1.1.1.3-1.el6.kolab_14 will be installiert
--> Verarbeite Abhängigkeiten: roundcubemail(skin-larry-assets) =
1.1.1.3-1.el6.kolab_14 für Paket:
roundcubemail-plugin-acl-skin-larry-assets-1.1.1.3-1.el6.kolab_14.noarch
---> Package roundcubemail-plugin-filesystem_attachments-assets.noarch
0:1.1.1.3-1.el6.kolab_14 will be installiert
---> Package roundcubemail-plugin-jqueryui-assets.noarch
0:1.1.1.3-1.el6.kolab_14 will be installiert
---> Package roundcubemail-plugin-jqueryui-skin-larry.noarch
0:1.1.1.3-1.el6.kolab_14 will be installiert
--> Verarbeite Abhängigkeiten: roundcubemail(plugin-jqueryui-skin-larry-assets)
= 1.1.1.3-1.el6.kolab_14 für Paket:
roundcubemail-plugin-jqueryui-skin-larry-1.1.1.3-1.el6.kolab_14.noarch
---> Package roundcubemail-plugin-managesieve-skin-larry-assets.noarch
0:1.1.1.3-1.el6.kolab_14 will be installiert
--> Verarbeite Abhängigkeiten: roundcubemail(skin-larry-assets) =
1.1.1.3-1.el6.kolab_14 für Paket:
roundcubemail-plugin-managesieve-skin-larry-assets-1.1.1.3-1.el6.kolab_14.noarch
---> Package roundcubemail-skin-larry.noarch 0:1.1.1.3-1.el6.kolab_14 will be
installiert
--> Verarbeite Abhängigkeiten: roundcubemail(skin-larry-assets) =
1.1.1.3-1.el6.kolab_14 für Paket:
roundcubemail-skin-larry-1.1.1.3-1.el6.kolab_14.noarch
---> Package roundcubemail-skin-larry-assets.noarch 0:1.1.1.59-2.1.el6.kolab_14
will be installiert
--> Führe Transaktionsprüfung aus
---> Package roundcubemail-plugin-acl-skin-larry-assets.noarch
0:1.1.1.3-1.el6.kolab_14 will be installiert
--> Verarbeite Abhängigkeiten: roundcubemail(skin-larry-assets) =
1.1.1.3-1.el6.kolab_14 für Paket:
roundcubemail-plugin-acl-skin-larry-assets-1.1.1.3-1.el6.kolab_14.noarch
---> Package roundcubemail-plugin-jqueryui-skin-larry-assets.noarch
0:1.1.1.3-1.el6.kolab_14 will be installiert
--> Verarbeite Abhängigkeiten: roundcubemail(skin-larry-assets) =
1.1.1.3-1.el6.kolab_14 für Paket:
roundcubemail-plugin-jqueryui-skin-larry-assets-1.1.1.3-1.el6.kolab_14.noarch
---> Package roundcubemail-plugin-managesieve-skin-larry-assets.noarch
0:1.1.1.3-1.el6.kolab_14 will be installiert
--> Verarbeite Abhängigkeiten: roundcubemail(skin-larry-assets) =
1.1.1.3-1.el6.kolab_14 für Paket:
roundcubemail-plugin-managesieve-skin-larry-assets-1.1.1.3-1.el6.kolab_14.noarch
---> Package roundcubemail-skin-larry.noarch 0:1.1.1.3-1.el6.kolab_14 will be
installiert
--> Verarbeite Abhängigkeiten: roundcubemail(skin-larry-assets) =
1.1.1.3-1.el6.kolab_14 für Paket:
roundcubemail-skin-larry-1.1.1.3-1.el6.kolab_14.noarch
--> Abhängigkeitsauflösung beendet
Fehler: Package:
roundcubemail-plugin-acl-skin-larry-assets-1.1.1.3-1.el6.kolab_14.noarch
(kolab-14-development)
            Requires: roundcubemail(skin-larry-assets) = 1.1.1.3-1.el6.kolab_14
            Available:
roundcubemail-skin-larry-assets-1.1-25.14.el6.kolab_14.noarch (kolab-14)
                roundcubemail(skin-larry-assets) = 1.1-25.14.el6.kolab_14
            Available:
roundcubemail-skin-larry-assets-1.1-25.15.el6.kolab_14.noarch
(kolab-14-updates-testing)
                roundcubemail(skin-larry-assets) = 1.1-25.15.el6.kolab_14
            Available:
roundcubemail-skin-larry-assets-1.1-25.17.el6.kolab_14.noarch
(kolab-14-updates-testing)
                roundcubemail(skin-larry-assets) = 1.1-25.17.el6.kolab_14
            Available:
roundcubemail-skin-larry-assets-1.1.0-1.el6.kolab_14.noarch
(kolab-14-updates-testing)
                roundcubemail(skin-larry-assets) = 1.1.0-1.el6.kolab_14
            Available:
roundcubemail-skin-larry-assets-1.1.0-2.el6.kolab_14.noarch
(kolab-14-updates-testing)
                roundcubemail(skin-larry-assets) = 1.1.0-2.el6.kolab_14
            Available:
roundcubemail-skin-larry-assets-1.1.0-4.el6.kolab_14.noarch
(kolab-14-updates-testing)
                roundcubemail(skin-larry-assets) = 1.1.0-4.el6.kolab_14
            Available:
roundcubemail-skin-larry-assets-1.1.1.3-1.el6.kolab_14.noarch
(kolab-14-development)
                roundcubemail(skin-larry-assets) = 1.1.1.3-1.el6.kolab_14
            Installieren:
roundcubemail-skin-larry-assets-1.1.1.59-2.1.el6.kolab_14.noarch
(kolab-14-development)
                roundcubemail(skin-larry-assets) = 1.1.1.59-2.1.el6.kolab_14
Fehler: Package: roundcubemail-skin-larry-1.1.1.3-1.el6.kolab_14.noarch
(kolab-14-development)
            Requires: roundcubemail(skin-larry-assets) = 1.1.1.3-1.el6.kolab_14
            Available:
roundcubemail-skin-larry-assets-1.1-25.14.el6.kolab_14.noarch (kolab-14)
                roundcubemail(skin-larry-assets) = 1.1-25.14.el6.kolab_14
            Available:
roundcubemail-skin-larry-assets-1.1-25.15.el6.kolab_14.noarch
(kolab-14-updates-testing)
                roundcubemail(skin-larry-assets) = 1.1-25.15.el6.kolab_14
            Available:
roundcubemail-skin-larry-assets-1.1-25.17.el6.kolab_14.noarch
(kolab-14-updates-testing)
                roundcubemail(skin-larry-assets) = 1.1-25.17.el6.kolab_14
            Available:
roundcubemail-skin-larry-assets-1.1.0-1.el6.kolab_14.noarch
(kolab-14-updates-testing)
                roundcubemail(skin-larry-assets) = 1.1.0-1.el6.kolab_14
            Available:
roundcubemail-skin-larry-assets-1.1.0-2.el6.kolab_14.noarch
(kolab-14-updates-testing)
                roundcubemail(skin-larry-assets) = 1.1.0-2.el6.kolab_14
            Available:
roundcubemail-skin-larry-assets-1.1.0-4.el6.kolab_14.noarch
(kolab-14-updates-testing)
                roundcubemail(skin-larry-assets) = 1.1.0-4.el6.kolab_14
            Available:
roundcubemail-skin-larry-assets-1.1.1.3-1.el6.kolab_14.noarch
(kolab-14-development)
                roundcubemail(skin-larry-assets) = 1.1.1.3-1.el6.kolab_14
            Installieren:
roundcubemail-skin-larry-assets-1.1.1.59-2.1.el6.kolab_14.noarch
(kolab-14-development)
                roundcubemail(skin-larry-assets) = 1.1.1.59-2.1.el6.kolab_14
Fehler: Package:
roundcubemail-plugin-jqueryui-skin-larry-assets-1.1.1.3-1.el6.kolab_14.noarch
(kolab-14-development)
            Requires: roundcubemail(skin-larry-assets) = 1.1.1.3-1.el6.kolab_14
            Available:
roundcubemail-skin-larry-assets-1.1-25.14.el6.kolab_14.noarch (kolab-14)
                roundcubemail(skin-larry-assets) = 1.1-25.14.el6.kolab_14
            Available:
roundcubemail-skin-larry-assets-1.1-25.15.el6.kolab_14.noarch
(kolab-14-updates-testing)
                roundcubemail(skin-larry-assets) = 1.1-25.15.el6.kolab_14
            Available:
roundcubemail-skin-larry-assets-1.1-25.17.el6.kolab_14.noarch
(kolab-14-updates-testing)
                roundcubemail(skin-larry-assets) = 1.1-25.17.el6.kolab_14
            Available:
roundcubemail-skin-larry-assets-1.1.0-1.el6.kolab_14.noarch
(kolab-14-updates-testing)
                roundcubemail(skin-larry-assets) = 1.1.0-1.el6.kolab_14
            Available:
roundcubemail-skin-larry-assets-1.1.0-2.el6.kolab_14.noarch
(kolab-14-updates-testing)
                roundcubemail(skin-larry-assets) = 1.1.0-2.el6.kolab_14
            Available:
roundcubemail-skin-larry-assets-1.1.0-4.el6.kolab_14.noarch
(kolab-14-updates-testing)
                roundcubemail(skin-larry-assets) = 1.1.0-4.el6.kolab_14
            Available:
roundcubemail-skin-larry-assets-1.1.1.3-1.el6.kolab_14.noarch
(kolab-14-development)
                roundcubemail(skin-larry-assets) = 1.1.1.3-1.el6.kolab_14
            Installieren:
roundcubemail-skin-larry-assets-1.1.1.59-2.1.el6.kolab_14.noarch
(kolab-14-development)
                roundcubemail(skin-larry-assets) = 1.1.1.59-2.1.el6.kolab_14
Fehler: Package:
roundcubemail-plugin-managesieve-skin-larry-assets-1.1.1.3-1.el6.kolab_14.noarch
(kolab-14-development)
            Requires: roundcubemail(skin-larry-assets) = 1.1.1.3-1.el6.kolab_14
            Available:
roundcubemail-skin-larry-assets-1.1-25.14.el6.kolab_14.noarch (kolab-14)
                roundcubemail(skin-larry-assets) = 1.1-25.14.el6.kolab_14
            Available:
roundcubemail-skin-larry-assets-1.1-25.15.el6.kolab_14.noarch
(kolab-14-updates-testing)
                roundcubemail(skin-larry-assets) = 1.1-25.15.el6.kolab_14
            Available:
roundcubemail-skin-larry-assets-1.1-25.17.el6.kolab_14.noarch
(kolab-14-updates-testing)
                roundcubemail(skin-larry-assets) = 1.1-25.17.el6.kolab_14
            Available:
roundcubemail-skin-larry-assets-1.1.0-1.el6.kolab_14.noarch
(kolab-14-updates-testing)
                roundcubemail(skin-larry-assets) = 1.1.0-1.el6.kolab_14
            Available:
roundcubemail-skin-larry-assets-1.1.0-2.el6.kolab_14.noarch
(kolab-14-updates-testing)
                roundcubemail(skin-larry-assets) = 1.1.0-2.el6.kolab_14
            Available:
roundcubemail-skin-larry-assets-1.1.0-4.el6.kolab_14.noarch
(kolab-14-updates-testing)
                roundcubemail(skin-larry-assets) = 1.1.0-4.el6.kolab_14
            Available:
roundcubemail-skin-larry-assets-1.1.1.3-1.el6.kolab_14.noarch
(kolab-14-development)
                roundcubemail(skin-larry-assets) = 1.1.1.3-1.el6.kolab_14
            Installieren:
roundcubemail-skin-larry-assets-1.1.1.59-2.1.el6.kolab_14.noarch
(kolab-14-development)
                roundcubemail(skin-larry-assets) = 1.1.1.59-2.1.el6.kolab_14
 Sie können versuchen --skip-broken zu benutzen, um das Problem zu umgehen.
 You could try running: rpm -Va --nofiles --nodigest


Is this a packaging issue or is the removal of development repo mandatory?

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.kolabsys.com/pipermail/packaging-bugs/attachments/20150714/39eba6b1/attachment-0001.htm>


More information about the packaging-bugs mailing list