[packaging] [Bug 5015] Kolab 3.4 installation fail on Debian 8.0 Jessie

Kolab Bugzilla noreply at kolab.org
Fri May 1 22:38:54 CEST 2015


https://issues.kolab.org/show_bug.cgi?id=5015

--- Comment #6 from Christoph Erhardt <kolab at sicherha.de> ---
The original reason for Kolab's custom Apache package was that older Debian
versions did not allow the co-installation of multiple Apaches with different
multi-processing models. That feature is needed by Kolab because 389-admin
depends on apache2-mpm-worker whereas everything else depends on
apache2-mpm-prefork. The solution at the time was to provide modified versions
of the Apache packages that are co-installable (using suffixed binaries).

That solution is no longer needed for Jessie because
1. in Apache 2.4, the MPM is loaded as a shared library instead of being
configured statically at compile time, so there are no longer multiple MPM
packages, and
2. the 389 directory server is now officially packaged in Debian.

Hence, I don't expect any MPM-related problems with Jessie's Apache package.
Let's kick the Debian_8.0 repository from the httpd package in OBS. :-)

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.kolabsys.com/pipermail/packaging-bugs/attachments/20150501/130df369/attachment.htm>


More information about the packaging-bugs mailing list