<html>
    <head>
      <base href="https://issues.kolab.org/" />
    </head>
    <body><table border="1" cellspacing="0" cellpadding="8">
        <tr>
          <th>Bug ID</th>
          <td><a class="bz_bug_link 
          bz_status_UNCONFIRMED "
   title="UNCONFIRMED --- - kolab 3.3 el7 rpms require mariadb-server, conflict with mariadb-galera-server"
   href="https://issues.kolab.org/show_bug.cgi?id=3981">3981</a>
          </td>
        </tr>

        <tr>
          <th>Summary</th>
          <td>kolab 3.3 el7 rpms require mariadb-server, conflict with mariadb-galera-server
          </td>
        </tr>

        <tr>
          <th>Classification</th>
          <td>Kolab Server
          </td>
        </tr>

        <tr>
          <th>Product</th>
          <td>Kolab Server
          </td>
        </tr>

        <tr>
          <th>Version</th>
          <td>3.3
          </td>
        </tr>

        <tr>
          <th>Hardware</th>
          <td>PC
          </td>
        </tr>

        <tr>
          <th>OS</th>
          <td>Linux
          </td>
        </tr>

        <tr>
          <th>Status</th>
          <td>UNCONFIRMED
          </td>
        </tr>

        <tr>
          <th>Severity</th>
          <td>normal
          </td>
        </tr>

        <tr>
          <th>Priority</th>
          <td>P3
          </td>
        </tr>

        <tr>
          <th>Component</th>
          <td>packaging
          </td>
        </tr>

        <tr>
          <th>Assignee</th>
          <td>packaging-bugs&#64;lists.kolabsys.com
          </td>
        </tr>

        <tr>
          <th>Reporter</th>
          <td>pasik&#64;iki.fi
          </td>
        </tr>

        <tr>
          <th>Ticket Type</th>
          <td>---
          </td>
        </tr></table>
      <p>
        <div>
        <pre>I have Kolab 3.3 environment, which was installed pretty much immediately when
kolab 3.3 centos7 packages first became available.

I'm running mariadb-galera-server from epel el7 repo, because this package
&quot;provides&quot; mysql-server, which was required be the early kolab 3.3 rpms:

# rpm -qa | grep ^kolab-3
kolab-3.1.8-4.2.el7.kolab_3.3.noarch

# rpm -q kolab --requires
kolab-cli
kolab-conf
kolab-imap
kolab-ldap
kolab-mta
kolab-saslauthd
kolab-server
kolab-utils
kolab-webadmin
kolab-webclient
mysql-server
rpmlib(CompressedFileNames) &lt;= 3.0.4-1
rpmlib(FileDigests) &lt;= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) &lt;= 4.0-1
rpmlib(PayloadIsXz) &lt;= 5.2-1

# rpm -q mariadb-galera-server --provides
config(mariadb-galera-server) = 1:5.5.37-2.el7
libdaemon_example.so()(64bit)
mariadb-galera-server = 1:5.5.37-2.el7
mariadb-galera-server(x86-64) = 1:5.5.37-2.el7
mysql-compat-server = 1:5.5.37-2.el7
mysql-compat-server(x86-64) = 1:5.5.37-2.el7
mysql-server = 1:5.5.37-2.el7
mysql-server(x86-64) = 1:5.5.37-2.el7


Running &quot;yum update&quot; today results in this:

Resolving Dependencies
--&gt; Running transaction check
---&gt; Package kolab.noarch 0:3.1.8-4.2.el7.kolab_3.3 will be updated
---&gt; Package kolab.noarch 0:3.1.8-4.4.el7.kolab_3.3 will be an update
--&gt; Processing Dependency: mariadb-server for package:
kolab-3.1.8-4.4.el7.kolab_3.3.noarch
--&gt; Running transaction check
---&gt; Package mariadb-server.x86_64 1:5.5.40-1.el7_0 will be installed
--&gt; Processing Dependency: mariadb-libs(x86-64) = 1:5.5.40-1.el7_0 for package:
1:mariadb-server-5.5.40-1.el7_0.x86_64
--&gt; Processing Dependency: mariadb(x86-64) = 1:5.5.40-1.el7_0 for package:
1:mariadb-server-5.5.40-1.el7_0.x86_64
--&gt; Running transaction check
---&gt; Package mariadb.x86_64 1:5.5.37-1.el7_0 will be updated
---&gt; Package mariadb.x86_64 1:5.5.40-1.el7_0 will be an update
---&gt; Package mariadb-libs.x86_64 1:5.5.37-1.el7_0 will be updated
---&gt; Package mariadb-libs.x86_64 1:5.5.40-1.el7_0 will be an update
--&gt; Processing Conflict: 1:mariadb-galera-server-5.5.37-2.el7.x86_64 conflicts
mariadb-server
--&gt; Finished Dependency Resolution
Error: mariadb-galera-server conflicts with
1:mariadb-server-5.5.40-1.el7_0.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


It seems kolab rpm now requires &quot;mariadb-server&quot; instead of &quot;mysql-server&quot;:

# rpm -qp kolab-3.1.8-4.4.el7.kolab_3.3.noarch.rpm --requires
kolab-cli
kolab-conf
kolab-imap
kolab-ldap
kolab-mta
kolab-saslauthd
kolab-server
kolab-utils
kolab-webadmin
kolab-webclient
mariadb-server
rpmlib(CompressedFileNames) &lt;= 3.0.4-1
rpmlib(FileDigests) &lt;= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) &lt;= 4.0-1
rpmlib(PayloadIsXz) &lt;= 5.2-1


Is it possible to change that &quot;requires&quot; to be mariadb-server OR
mariadb-galera-server ?  mariadb-galera-server is an option that should be
allowed to be used together with kolab. 

It'd be nice if mariadb-galera-server provided &quot;mariadb-server&quot; though.. but
that doesn't seem to be the case today.</pre>
        </div>
      </p>
      <hr>
      <span>You are receiving this mail because:</span>
      
      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>