<html>
    <head>
      <base href="https://issues.kolab.org/" />
    </head>
    <body>
      <p>
        <div>
            <b><a class="bz_bug_link 
          bz_status_UNCONFIRMED "
   title="UNCONFIRMED --- - kolab 3.3 el7 rpms require mariadb-server, conflict with mariadb-galera-server"
   href="https://issues.kolab.org/show_bug.cgi?id=3981#c1">Comment # 1</a>
              on <a class="bz_bug_link 
          bz_status_UNCONFIRMED "
   title="UNCONFIRMED --- - kolab 3.3 el7 rpms require mariadb-server, conflict with mariadb-galera-server"
   href="https://issues.kolab.org/show_bug.cgi?id=3981">bug 3981</a>
              from <span class="vcard"><a class="email" href="mailto:pasik&#64;iki.fi" title="pasik&#64;iki.fi">pasik&#64;iki.fi</a>
</span></b>
        <pre>
Investigating this a bit more.. actually it seems mariadb-galera-server has
been retired from epel7, so it's not available anymore in the epel7 repository.

So basicly new kolab 3.3 users won't hit this dependency problem. 

This problem only happens with users who previously installed
mariadb-galera-server when it was still available in epel7, and now try to
update to most recent kolab 3.3 updates.

I can see two options:

1) dump the databases, remove mariadb-galera-server, install mariadb-server,
and restore the databases.

2) Fix kolab rpms to have a dependency for mariadb-server OR mysql-server, if
it's possible to have OR in the dependencies. That would make the rpm/yum
dependencies happy about having mariadb-galera-server installed instead of
mariadb-server.</pre>
        </div>
      </p>
      <hr>
      <span>You are receiving this mail because:</span>
      
      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>