[packaging] Branch 'ubuntu/precise/enterprise/e3' - 2 commits - debian/changelog debian/control

Andre Heinecke "andre.heinecke at intevation.de" at kolabsys.com
Tue Jun 5 13:02:04 CEST 2012


 debian/changelog |    6 ++++
 debian/control   |   68 ++++++++++++++++++++++++++++++++++++++++++++++++++++---
 2 files changed, 71 insertions(+), 3 deletions(-)

New commits:
commit 6cd3d954445164fee557a1c4c3c3ffd128e050ed
Author: Andre Heinecke <aheinecke at intevation.de>
Date:   Tue Jun 5 11:01:57 2012 +0000

    Add conflict again

diff --git a/debian/control b/debian/control
index b0cf546..eb84523 100644
--- a/debian/control
+++ b/debian/control
@@ -34,7 +34,8 @@ Depends: akregator (>= ${binary:Version}), kaddressbook (>= ${binary:Version}),
          libksieve0 (>= ${binary:Version}), libktnef1 (>= ${binary:Version}),
          libmimelib1c2a (>= ${binary:Version})
 Suggests: kdepim-doc-html
-Conflicts: kdepim (>= 4:4.0.0)
+Conflicts: kdepim (>= 4:4.0.0), kopete
+Replaces: kopete
 Recommends: kde3-i18n-de, drkonqi3-compat, kdepim-dbg (>= ${binary:Version}), akonadi-disabler
 Description: Personal Information Management apps from the official KDE release
  KDE (the K Desktop Environment) is a powerful Open Source graphical


commit 4b8a80d9d01fb7e1ed10b9c771e6a8f693c357da
Author: Andre Heinecke <aheinecke at intevation.de>
Date:   Tue Jun 5 09:39:22 2012 +0000

    Add metapackages that don't conflict
    
    Conflicts:
    
    	debian/changelog
    	debian/control

diff --git a/debian/changelog b/debian/changelog
index a052449..2466c04 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+kdepim (4:3.5.10.enterprise.0.20110424.6842210-kk3) precise; urgency=low
+
+  * Add metpackages that don't conflict 
+
+ -- Andre Heinecke <aheinecke at intevation.de>  Tue, 05 Jun 2012 09:28:15 +0000
+
 kdepim (4:3.5.10.enterprise.0.20110424.6842210-kk2) precise; urgency=low
 
   * Fix gnupg-agent problems by adding it to autostart and removing
diff --git a/debian/control b/debian/control
index da26fdd..b0cf546 100644
--- a/debian/control
+++ b/debian/control
@@ -664,6 +664,8 @@ Description: KDE mime library [development]
  This package is part of KDE, and a component of the KDE PIM module.
  See the 'kde' and 'kdepim' packages for more information.
 
+# Remove dependencies of the meta packages that conflict with us.
+
 Package: kde-standard-e35
 Architecture: all
 Provides: kde-standard
@@ -688,6 +690,33 @@ Description: KDE Plasma Desktop and standard set of applications
  The e35 variant is adopted so that it does not Conflict with Kontact
  Enterprise 3.5
 
+Package: kde-full-e35
+Architecture: all
+Depends: ${misc:Depends}, kde-plasma-desktop,
+ kde-plasma-netbook, kdeadmin,
+ kdeartwork, kdegraphics, kdeedu,
+ kdegames, kdemultimedia, kdenetwork-e35,
+ kdeutils, kdeplasma-addons, kdepim
+Recommends: kde-standard-e35,
+ kdeaccessibility, kdesdk,
+ kdetoys, kdewebdev
+Suggests: kde-l10n, koffice ( >= 1:2.0.0), xorg
+Provides: kde-full, kde-software-compilation
+Replaces: kde-full
+Conflicts: kde-full
+Breaks: kde-minimal (<< 5:57)
+Description: the complete KDE Software Compilation for end users
+ KDE is the powerful, integrated, and easy-to-use Free Software desktop
+ platform and suite of applications.
+ .
+ This metapackage includes all the official modules released with KDE Sotware
+ Compilation that are not specific to development and as well other KDE
+ applications that are useful for a desktop user. This includes multimedia,
+ networking, graphics, education, games, system administration tools, and other
+ artwork and utilities.
+ The e35 variant removes Software that conflicts with Kontact Enterprise 3.5
+ from the list of dependencies. (e.g. Kmail2)
+
 Package: kdenetwork-e35
 Conflicts: kdenetwork
 Provides: kdenetwork
@@ -705,5 +734,37 @@ Description: networking applications from the official KDE 4 release
  .
  This metapackage includes networking applications provided with the official
  release of KDE.
- The e35 variant has adopted dependencies so that it does not conflict with
- Kontact enterprise 3.5
+ The e35 variant removes Software that conflicts with Kontact Enterprise 3.5
+ from the list of dependencies. Namely Kopete.
+
+# The following is to remove version requirements and are otherwise
+# not modified
+
+Package: kde-core
+Architecture: all
+Depends: kde-standard
+Description: a dummy transitional package (lenny to squeeze)
+ This transitional package exists purely to ensure smooth upgrades from lenny
+ to squeeze. For new installations please choose one of kde-standard (highly
+ recommended), kde-plasma-desktop, kde-plasma-netbook or kde-full metapackages.
+
+Package: kde
+Architecture: all
+Depends: kde-full
+Description: a dummy transitional package (lenny to squeeze)
+ This transitional package exists purely to ensure smooth upgrades from lenny
+ to squeeze. For new installations please choose one of kde-standard (highly
+ recommended), kde-full, kde-plasma-desktop or kde-plasma-netbook metapackages.
+
+Package: kdebase
+Architecture: all
+Depends: ${misc:Depends}, kde-plasma-desktop
+Recommends: kde-standard
+Suggests: kde-l10n
+Breaks: kde-minimal (<< 5:57)
+Description: the K Desktop Environment, base applications
+ KDE is the powerful, integrated, and easy-to-use Free Software desktop
+ platform and suite of applications.
+ .
+ This metapackage is to ease the upgrade from KDE 3 and pulls in the core parts 
+ of KDE, which is now represented by the packages providing kde-plasma-desktop. 




More information about the packaging-commits mailing list